Infostealers without borders: macOS, Python stealers, and platform abuse
Infostealer threatsΒ are rapidly expanding beyondΒ traditional Windows-focused campaigns, increasingly targeting macOS environments,Β leveragingΒ cross-platform languages such as Python, and abusing trusted platforms and utilities to silently deliver credential-stealing malware at scale. Since late 2025, Microsoft Defender Experts has observedΒ macOS targeted infostealerΒ campaigns using social engineering techniquesβincludingΒ ClickFix-style prompts and malicious DMG installersβto deploy macOS-specific infostealers such asΒ DigitStealer,Β MacSync, and Atomic macOS Stealer (AMOS).Β
These campaigns leverage fileless execution, native macOS utilities, and AppleScript automation to harvest credentials, session data, secrets from browsers, keychains, and developer environments. Simultaneously, Python-based stealers are being leveraged by attackers to rapidly adapt, reuse code, and target heterogeneous environments with minimal overhead. Other threat actors are abusing trusted platforms and utilitiesβincluding WhatsApp and PDF converter toolsβto distribute malware like Eternidade Stealer and gain access to financial and cryptocurrency accounts.
This blogΒ examines how modern infostealers operate across operating systems and delivery channels by blending into legitimate ecosystems and evading conventionalΒ defenses. We provide comprehensive detection coverage through Microsoft Defender XDR and actionable guidance to help organizations detect, mitigate, and respond to these evolving threats.Β
Activity overviewΒ
macOS users are being targeted through fake software and browser tricksΒ
Mac usersΒ areΒ encounteringΒ deceptive websitesβoften through GoogleΒ Ads or malicious advertisementsβthat either prompt them to download fake applications or instruct them to copy and paste commands into their Terminal. These βClickFixβ style attacks trick users into downloading malware that steals browser passwords, cryptocurrency wallets, cloud credentials, and developer access keys.Β
Three major Mac-focused stealer campaignsΒ includeΒ DigitStealerΒ (distributed through fakeΒ DynamicLakeΒ software),Β MacSyncΒ (delivered via copy-paste Terminal commands), and Atomic Stealer (using fake AI tool installers). All three harvest the same types of dataβbrowser credentials, saved passwords, cryptocurrency wallet information, and developer secretsβthen send everything to attacker servers beforeΒ deletingΒ traces of the infection.Β
Stolen credentials enable account takeovers across banking, email, social media, and corporate cloud services. Cryptocurrency wallet theft can result in immediateΒ financial loss. For businesses, compromised developer credentials can provide attackers with access to source code, cloud infrastructure, and customer data.Β
Phishing campaigns are delivering Python-based stealers to organizationsΒ
The proliferation of Python information stealers has become an escalating concern. This gravitation towards Python is driven by ease of use and the availability of tools and frameworks allowing quick development, even for individuals with limited coding knowledge. Due to this, Microsoft Defender Experts observed multiple Python-based infostealer campaigns over the past year. They are typically distributed via phishing emails and collect login credentials, session cookies, authentication tokens, credit card numbers, and crypto wallet data.
PXA Stealer, one of the most notable Python-based infostealers seen in 2025, harvests sensitive data including login credentials, financial information, and browser data. Linked to Vietnamese-speaking threat actors, it targets government and education entities through phishing campaigns. In October 2025 and December 2025, Microsoft Defender Experts investigated two PXA Stealer campaigns that used phishing emails for initial access, established persistence via registry Run keys or scheduled tasks, downloaded payloads from remote locations, collected sensitive information, and exfiltrated the data via Telegram. To evade detection, we observed the use of legitimate services such as Telegram for command-and-control communications, obfuscated Python scripts, malicious DLLs being sideloaded, Python interpreter masquerading as a system process (i.e., svchost.exe), and the use of signed and living off the land binaries.
Due to the growing threat of Python-based infostealers, it is important that organizations protect their environment by being aware of the tactics, techniques, and procedures used by the threat actors who deploy this type of malware. Being compromised by infostealers can lead to data breaches, unauthorized access to internal systems, business email compromise (BEC), supply chain attacks, and ransomware attacks.
Attackers are weaponizing WhatsApp and PDF tools to spreadΒ infostealersΒ
Since late 2025, platform abuse has become an increasingly prevalent tactic wherein adversaries deliberately exploit the legitimacy, scale, and user trust associated with widely used applications and services.Β
WhatsApp Abused to Deliver Eternidade Stealer: During November 2025, Microsoft Defender Experts identified a WhatsApp platform abuse campaign leveraging multi-stage infection and worm-like propagation to distribute malware. The activity begins with an obfuscated Visual Basic script that drops a malicious batch file launching PowerShell instances to download payloads.
One of the payloads is a Python script that establishes communication with a remote server and leverages WPPConnect to automate message sending from hijacked WhatsApp accounts, harvests the victimβs contact list, and sends malicious attachments to all contacts using predefined messaging templates. Another payload is a malicious MSI installer that ultimately delivers Eternidade Stealer, a Delphi-based credential stealer that continuously monitors active windows and running processes for strings associated with banking portals, payment services, and cryptocurrency exchanges including Bradesco, BTG Pactual, MercadoPago, Stripe, Binance, Coinbase, MetaMask, and Trust Wallet.
Malicious Crystal PDF installer campaign: In September 2025, Microsoft Defender Experts discovered a malicious campaign centered on an application masquerading as a PDF editor named Crystal PDF. The campaign leveraged malvertising and SEO poisoning through Google Ads to lure users. When executed, CrystalPDF.exe establishes persistence via scheduled tasks and functions as an information stealer, covertly hijacking Firefox and Chrome browsers to access sensitive files in AppData\Roaming, including cookies, session data, and credential caches.
Mitigation and protection guidanceΒ
Microsoft recommends the following mitigations to reduce the impact of the macOSβfocused, Pythonβbased, and platformβabuse infostealer threats discussed in this report. These recommendations draw from established Defender blog guidance patterns and align with protections offered across Microsoft Defender XDR.Β
Organizations can follow these recommendations to mitigate threats associated with this threat:Β Β Β Β Β Β Β Β Β Β Β Β Β
Strengthen user awareness & execution safeguardsΒ
- Educate users on socialβengineering lures, including malvertising redirect chains, fake installers, andΒ ClickFixβstyle copyβpaste prompts common across macOS stealer campaigns such asΒ DigitStealer,Β MacSync, and AMOS.Β
- Discourage installation of unsigned DMGs or unofficial βterminalβfixβ utilities; reinforce safeβdownload practices for consumer and enterprise macOS systems.Β
Harden macOS environments against native tool abuseΒ
- Monitor for suspicious Terminal activityβespecially execution flows involving curl, Base64 decoding,Β gunzip,Β osascript, or JXA invocation, which appear across all three macOS stealers.Β
- Detect patterns of fileless execution,Β such as inβmemory pipelines using curl | base64 -d |Β gunzip, or AppleScriptβdriven system discovery and credential harvesting.Β
- Leverage Defenderβs custom detectionΒ rulesΒ to alert on abnormal access to Keychain, browser credential stores, and cloud/developer artifacts, including SSH keys, Kubernetes configs, AWS credentials, and wallet data.Β
Control outbound traffic & stagingΒ behaviorΒ
- Inspect network egress for POST requests to newly registered or suspicious domainsβa key indicator forΒ DigitStealer,Β MacSync, AMOS, and Pythonβbased stealer campaigns.Β
- Detect transient creation of ZIP archives under /tmpΒ or similar ephemeral directories, followed byΒ outbound exfiltration attempts.Β
- Block direct access to known C2 infrastructureΒ where possible, informed by your organizationβs threatβintelligence sources.Β
Protect against Python-based stealers & cross-platform payloadsΒ
- Harden endpointΒ defensesΒ around LOLBIN abuse, such as certutil.exe decoding malicious payloads.Β
- Evaluate activity involvingΒ AutoItΒ and process hollowing, common in platformβabuse campaigns.Β
Microsoft also recommends the following mitigationsΒ to reduce the impact of this threat:Β
- Turn onβ―cloud-delivered protectionβ―in Microsoft Defender Antivirus or the equivalent for your antivirus product to cover rapidly evolving attacker tools and techniques. Cloud-based machine learning protections block a majority of new and unknown threats.Β
- Runβ―EDR in block modeβ―so that Microsoft Defender for Endpoint can block malicious artifacts, even when your non-Microsoft antivirus does not detect the threat or when Microsoft Defender Antivirus is running in passive mode. EDR in block mode works behind the scenes to remediate malicious artifacts that are detected post-breach.Β
- Enable network protection and web protection in Microsoft Defender for Endpoint to safeguard against malicious sites and internet-based threats.Β
- Encourage users to use Microsoft Edge and other web browsers that support Microsoft Defender SmartScreen, whichΒ identifiesΒ and blocks malicious websites, including phishing sites,Β scamΒ sites, and sites that host malware.Β
- Allowβ―investigation and remediationβ―in full automated mode to allow Microsoft Defender for Endpoint to take immediate action on alerts to resolve breaches, significantly reducing alert volume.Β
- Turn onβ―tamper protection featuresβ―to prevent attackers from stopping security services. Combine tamper protection with theβ―DisableLocalAdminMergeβ―setting to prevent attackers from using local administrator privileges to set antivirus exclusions.Β
- Microsoft Defender XDR customers can also implement the following attack surface reduction rules to harden an environment against LOLBAS techniques used by threat actors:Β
Microsoft Defender XDR detectionsΒ
Microsoft Defender XDR customers can refer to the list of applicable detections below. Microsoft Defender XDR coordinates detection, prevention, investigation, and response across endpoints, identities, email, and apps to provide integrated protection against attacks like the threat discussed in this blog.Β
Customers with provisioned access can also useΒ Microsoft Security Copilot in Microsoft DefenderΒ to investigate and respond to incidents, hunt for threats, and protect their organization with relevant threat intelligence.Β Β
| Tacticβ―Β Β | Observed activityβ―Β Β | Microsoft Defender coverageβ―Β Β |
| ExecutionΒ | EncodedΒ powershellΒ commands downloading payloadΒ Execution ofΒ various commands and scripts viaΒ osascriptΒ andΒ shΒ | Microsoft Defender for EndpointΒ SuspiciousΒ PowershellΒ download or encoded command executionΒ Β Β Suspicious shell command executionΒ Suspicious AppleScript activityΒ Suspicious script launchedΒ Β |
| PersistenceΒ | Registry Run key createdΒ Scheduled task created for recurring executionΒ LaunchAgentΒ orΒ LaunchDaemonΒ for recurring executionΒ | Microsoft Defender for EndpointΒ Anomaly detected in ASEP registryΒ Suspicious Scheduled Task LaunchedΒ SuspiciousΒ PslistΒ modificationsΒ SuspiciousΒ launchctlΒ tool activity Microsoft Defender AntivirusΒ Trojan:AtomicSteal.FΒ |
| DefenseΒ EvasionΒ | Unauthorized code executionΒ facilitatedΒ by DLL sideloadingΒ andΒ process injectionΒ Renamed Python interpreterΒ executesΒ obfuscated Python scriptΒ Decode payload withΒ certutilΒ RenamedΒ AutoITΒ interpreter binary andΒ AutoITΒ scriptΒ Delete data staging directoriesΒ | Microsoft Defender for EndpointΒ An executable file loaded an unexpected DLL fileΒ A process was injected with potentially malicious codeΒ Suspicious Python binary executionΒ SuspiciousΒ certutilΒ activityΒ Obfuseβ malware was preventedΒ RenameΒ AutoITΒ toolΒ Suspicious path deletionΒ Microsoft Defender AntivirusΒ Trojan:Script/Obfuse!MSRΒ |
| Credential AccessΒ | Credential and Secret HarvestingΒ Cryptocurrency probingΒ | Microsoft Defender for EndpointΒ Possible theftΒ of passwords and other sensitive web browser informationΒ Suspicious access of sensitive filesΒ Suspicious process collected data from local systemΒ Unix credentials were illegitimately accessedΒ |
| DiscoveryΒ | System information queriedΒ using WMI and PythonΒ | Microsoft Defender for EndpointΒ Suspicious System Hardware DiscoveryΒ Suspicious Process DiscoveryΒ Suspicious Security Software DiscoveryΒ Suspicious Peripheral Device DiscoveryΒ |
| Command and ControlΒ | Communication toΒ command and controlΒ serverΒ | Microsoft Defender for EndpointΒ Suspicious connection to remote serviceΒ |
| CollectionΒ | Sensitive browser information compressed into ZIP file for exfiltrationΒ Β | Microsoft Defender for EndpointΒ Compression of sensitive dataΒ Suspicious Staging of Data Suspicious archive creationΒ |
| Β ExfiltrationΒ | Exfiltration through curlΒ | Microsoft Defender for EndpointΒ Suspicious file or content ingressΒ Remote exfiltration activityΒ Network connection byΒ osascriptΒ |
Threat intelligence reportsΒ
Microsoft customers can use the following reports in Microsoft products to get the most up-to-date information about the threat actor, malicious activity, and techniques discussed in this blog. These reports provide the intelligence, protection information, and recommended actions to prevent, mitigate, or respond to associated threats found in customer environments.Β
Microsoft DefenderΒ XDRΒ Threat analyticsΒ Β Β
- From ClickFix to code signed: the quiet shift of MacSync Stealer malware
- Malicious Crystal PDF installer campaign
Hunting queriesΒ Β Β
Microsoft Defender XDRΒ Β
Microsoft Defender XDR customers can run the following queries to find related activity in their networks:Β
Use the following queries toΒ identifyΒ activity related toΒ DigitStealerΒ
// Identify suspicious DynamicLake disk image (.dmg) mounting
DeviceProcessEvents
| where FileName has_any ('mount_hfs', 'mount')
| where ProcessCommandLine has_all ('-o nodev' , '-o quarantine')
| where ProcessCommandLine contains '/Volumes/Install DynamicLake'
// Identify data exfiltration to DigitStealer C2 API endpoints.
DeviceProcessEvents
| where InitiatingProcessFileName has_any ('bash', 'sh')
| where ProcessCommandLine has_all ('curl', '--retry 10')
| where ProcessCommandLine contains 'hwid='
| where ProcessCommandLine endswith "api/credentials"
or ProcessCommandLine endswith "api/grabber"
or ProcessCommandLine endswith "api/log"
| extend APIEndpoint = extract(@"/api/([^\s]+)", 1, ProcessCommandLine)
Use the following queries to identify activity related to MacSync
// Identify exfiltration of staged data via curl
DeviceProcessEvents
| where InitiatingProcessFileName =~ "zsh" and FileName =~ "curl"
| where ProcessCommandLine has_all ("curl -k -X POST -H", "api-key: ", "--max-time", "-F file=@/tmp/", ".zip", "-F buildtxd=")
Use the following queries to identify activity related to Atomic Stealer (AMOS)
// Identify suspicious AlliAi disk image (.dmg) mounting
DeviceProcessEvents
| where FileName has_any ('mount_hfs', 'mount')
| where ProcessCommandLine has_all ('-o nodev', '-o quarantine')
| where ProcessCommandLine contains '/Volumes/ALLI'
Use the following queries to identify activity related to PXA Stealer: Campaign 1
// Identify activity initiated by renamed python binary DeviceProcessEvents | where InitiatingProcessFileName endswith "svchost.exe" | where InitiatingProcessVersionInfoOriginalFileName == "pythonw.exe" // Identify network connections initiated by renamed python binary DeviceNetworkEvents | where InitiatingProcessFileName endswith "svchost.exe" | where InitiatingProcessVersionInfoOriginalFileName == "pythonw.exe"
Use the following queries to identify activity related to PXA Stealer: Campaign 2
// Identify malicious Process Execution activity
DeviceProcessEvents
| where ProcessCommandLine has_all ("-y","x",@"C:","Users","Public", ".pdf") and ProcessCommandLine has_any (".jpg",".png")
// Identify suspicious process injection activity
DeviceProcessEvents
| where FileName == "cvtres.exe"
| where InitiatingProcessFileName has "svchost.exe"
| where InitiatingProcessFolderPath !contains "system32"
Use the following queries to identify activity related to WhatsApp Abused to Deliver Eternidade Stealer
// Identify the files dropped from the malicious VBS execution
DeviceFileEvents
| where InitiatingProcessCommandLine has_all ("Downloads",".vbs")
| where FileName has_any (".zip",".lnk",".bat") and FolderPath has_all ("\\Temp\\")
// Identify batch script launching powershell instances to drop payloads
DeviceProcessEvents
| where InitiatingProcessParentFileName == "wscript.exe" and InitiatingProcessCommandLine β―has_any ("instalar.bat","python_install.bat")
| where ProcessCommandLine !has "conhost.exe"
// Identify AutoIT executable invoking malicious AutoIT script
DeviceProcessEvents
| where InitiatingProcessCommandLine β― has ".log" and InitiatingProcessVersionInfoOriginalFileName == "Autoit3.exe"
Use the following queries to identify activity related to Malicious CrystalPDF Installer Campaign
// Identify network connections to C2 domains DeviceNetworkEvents | where InitiatingProcessVersionInfoOriginalFileName == "CrystalPDF.exe" // Identify scheduled task persistence DeviceEvents | where InitiatingProcessVersionInfoProductName == "CrystalPDF" | where ActionType == "ScheduledTaskCreated
Indicators of compromiseΒ
| IndicatorΒ | TypeΒ | DescriptionΒ | |
| 3e20ddb90291ac17cef9913edd5ba91cd95437da86e396757c9d871a82b1282aΒ da99f7570b37ddb3d4ed650bc33fa9fbfb883753b2c212704c10f2df12c19f63Β | SHA-256Β | Payloads related toΒ DigitStealerΒ campaignΒ | |
| 42d51feea16eac568989ab73906bbfdd41641ee3752596393a875f85ecf06417Β | SHA-256Β | Payload related to Atomic Stealer (AMOS)Β | |
| 2c885d1709e2ebfcaa81e998d199b29e982a7559b9d72e5db0e70bf31b183a5fββΒ 6168d63fad22a4e5e45547ca6116ef68bb5173e17e25fd1714f7cc1e4f7b41e1Β Β 3bd6a6b24b41ba7f58938e6eb48345119bbaf38cd89123906869fab179f27433Β Β Β 5d929876190a0bab69aea3f87988b9d73713960969b193386ff50c1b5ffeadd6β―Β Β bdd2b7236a110b04c288380ad56e8d7909411da93eed2921301206de0cb0dda1Β Β Β 495697717be4a80c9db9fe2dbb40c57d4811ffe5ebceb9375666066b3dda73c3Β Β Β de07516f39845fb91d9b4f78abeb32933f39282540f8920fe6508057eedcbbeaΒ Β | SHA-256Β | Payloads related to WhatsApp malware campaignΒ | |
| 598da788600747cf3fa1f25cb4fa1e029eca1442316709c137690e645a0872bbΒ 3bc62aca7b4f778dabb9ff7a90fdb43a4fdd4e0deec7917df58a18eb036fac6eΒ c72f8207ce7aebf78c5b672b65aebc6e1b09d00a85100738aabb03d95d0e6a95Β | SHA-256Β | Payloads related to Malicious Crystal PDF installer campaignΒ Β | |
| 9d867ddb54f37592fa0ba1773323e2ba563f44b894c07ebfab4d0063baa6e777Β 08a1f4566657a07688b905739055c2e352e316e38049487e5008fc3d1253d03bΒ 5970d564b5b2f5a4723e548374d54b8f04728473a534655e52e5decef920e733Β 59855f0ec42546ce2b2e81686c1fbc51e90481c42489757ac03428c0daee6dfeΒ a5b19195f61925ede76254aaad942e978464e93c7922ed6f064fab5aad901efcΒ e7237b233fc6fda614e9e3c2eb3e03eeea94f4baf48fe8976dcc4bc9f528429eΒ 59347a8b1841d33afdd70c443d1f3208dba47fe783d4c2015805bf5836cff315Β e965eb96df16eac9266ad00d1087fce808ee29b5ee8310ac64650881bc81cf39Β | SHA-256Β | Payloads related to PXA Stealer: Campaign 1Β | |
| hxxps://allecos[.]de/DocumentaciΓ³n_del_expediente_de_derechos_de_autor_del_socio.zipΒ Β | URLΒ | Used to deliver initial access ZIP file (PXA Stealer: Campaign 1)Β | |
| hxxps://bagumedios[.]cloud/assets/media/others/ADN/pureΒ | URLΒ | Used to deliverΒ PureRATΒ payload (PXA Stealer: Campaign 1)Β | |
| hxxp://concursal[.]macquet[.]de/uid_page=244739642061129Β hxxps://tickets[.]pfoten-prinz[.]de/uid_page=118759991475831Β | URLΒ | URL contained in phishing email (PXA Stealer: Campaign 1)Β | |
| hxxps://erik22[.]carrd.coΒ | URLΒ | Used in make network connection andΒ subsequentΒ redirection in (PXA Stealer: Campaign 2)Β | |
| hxxps://erik22jomk77[.]card.coΒ | URLΒ | Used in make network connection andΒ subsequentΒ redirection in (PXA Stealer: Campaign 2)Β | |
| hxxps[:]//empautlipa[.]com/altor/installer[.]msiΒ | URLΒ | Used to deliver VBSΒ initialΒ access payload (WhatsApp Abused to DeliverΒ EternidadeΒ Stealer)Β | |
| 217.119.139[.]117Β | IP AddressΒ | AMOS C2 server (AMOS campaign)Β | |
| 157[.]66[.]27[.]11Β Β | IP AddressΒ Β | PureRATΒ C2 server (PXA Stealer: Campaign 1)Β | |
| 195.24.236[.]116Β | IP AddressΒ | C2 server (PXA Stealer: Campaign 2)Β | |
| dynamiclake[.]orgΒ | DomainΒ | Deceptive domain used to deliver unsigned diskΒ image. (DigitStealerΒ campaign)Β | |
| booksmagazinetx[.]comΒ goldenticketsshop[.]comΒ | DomainΒ | C2 servers (DigitStealerΒ campaign)Β Β | |
| b93b559cf522386018e24069ff1a8b7a[.]pages[.]devΒ 67e5143a9ca7d2240c137ef80f2641d6[.]pages[.]devΒ | DomainΒ | CloudFlareΒ Pages hosting payloads. (DigitStealerΒ campaign)Β | |
| barbermoo[.]couponsΒ barbermoo[.]funΒ barbermoo[.]shopΒ barbermoo[.]spaceΒ barbermoo[.]todayΒ barbermoo[.]topΒ barbermoo[.]worldΒ barbermoo[.]xyzΒ | DomainΒ | C2 servers (MacSyncΒ Stealer campaign)Β | |
| alli-ai[.]proΒ | DomainΒ | Deceptive domain that redirects user after CAPTCHA verification (AMOS campaign)Β | |
| ai[.]foqguzz[.]comΒ | DomainΒ | Redirected domain used to deliver unsigned disk image. (AMOS campaign)Β | |
| day.foqguzz[.]comΒ | DomainΒ | C2 server (AMOS campaign)Β | |
| bagumedios[.]cloudΒ | DomainΒ | C2 server (PXA Stealer: Campaign 1)Β | |
| Negmari[.]comΒ Β Ramiort[.]comΒ Β Strongdwn[.]comΒ | DomainΒ | C2 servers (Malicious Crystal PDF installer campaign)Β | |
Microsoft SentinelΒ Β
Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with βTI mapβ) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from theΒ Microsoft Sentinel Content HubΒ to have the analytics rule deployed in their Sentinel workspace.Β Β Β
ReferencesΒ Β
- MacSync Stealer Evolves: From ClickFix to Code-Signed Swift Malware β Jamf Threat LabsΒ Β
- Infostealers Strike Again: Malicious Installers Pass Through EDRs UndetectedΒ
- SpiderLabs IDs New Banking Trojan Distributed Through WhatsAppΒ
- A Vietnamese threat actorβs shift from PXA Stealer to PureRAT | HuntressΒ
- Ghost in the Zip | New PXA Stealer and Its Telegram-Powered Ecosystem | SentinelOneΒ
- Information-Stealing Malware Distribution Campaign Using Emails Disguised as Copyright Infringement Notices β wizSafe Security Signal -Guideposts to Safety and Security- IIJΒ
This research is provided by Microsoft Defender Security Research with contributions fromΒ Felicia Carter, Kajhon Soyini, Balaji Venkatesh S, Sai Chakri Kandalai, Dietrich Nembhard, Sabitha S, and Shriya Maniktala.
Learn moreΒ Β Β
ReviewΒ ourΒ documentationΒ to learnΒ more about our real-time protection capabilities and see howΒ toΒ enable them within yourΒ organization.Β Β
Learn more aboutΒ securing Copilot Studio agents with Microsoft DefenderΒ
Learn more aboutΒ Protect your agents in real-time during runtime (Preview) β Microsoft Defender for Cloud Apps | Microsoft LearnΒ Β
ExploreΒ how to build and customize agents with Copilot Studio Agent BuilderΒ Β
The post Infostealers without borders: macOS, Python stealers, and platform abuse appeared first on Microsoft Security Blog.






